青龙依赖安装与检查

依赖安装

docker exec -it 容器名/容器ID bash -c "npm install -g date-fns axios require request fs crypto-js crypto dotenv png-js tough-cookie got ts-node typescript @types/node ts-md5 tslib jsdom prettytable 

首先进入容器内

docker exec -it ID bash

 

然后把下面的命令都复制进去,执行,然后等一会执行结束就行

package_name="canvas png-js date-fns axios crypto crypto-js ts-md5 tslib @types/node dotenv typescript fs require jsdom json5 form-data jsdom -g js-base64 tough-cookie global-agent fs ws@7.4.3 ts-node prettytable"

for i in $package_name; do
    case $i in
        canvas)
            cd /ql/scripts
            npm ls $i
            ;;
        *)
            npm ls $i -g
            ;;
    esac
done

 

大概需要的依赖就这些,可以对照一下,有可能我的也不全,欢迎补充

root@bbb-PC:/home/bbb# docker exec -it QL2 bash
root@qinglong2:/ql $ package_name="canvas png-js date-fns axios crypto crypto-js ts-md5 tslib @types/node dotenv typescript fs require jsdom json5 form-data jsdom -g js-base64 tough-cookie global-agent fs ws@7.4.3 ts-node prettytable"
root@qinglong2:/ql $ 
root@qinglong2:/ql $ for i in $package_name; do
>     case $i in
>         canvas)
>             cd /ql/scripts
>             npm ls $i
>             ;;
>         *)
>             npm ls $i -g
>             ;;
>     esac
> done
dependence@ /ql/scripts
└── canvas@2.8.0 extraneous

/usr/local/lib
└── png-js@1.0.0

/usr/local/lib
└── date-fns@2.25.0

/usr/local/lib
└── axios@0.24.0

/usr/local/lib
└── (empty)

/usr/local/lib
└── crypto-js@4.1.1

/usr/local/lib
└── ts-md5@1.2.9

/usr/local/lib
└── tslib@2.3.1

/usr/local/lib
└── @types/node@16.11.6

/usr/local/lib
└── dotenv@10.0.0

/usr/local/lib
└── typescript@4.4.4

/usr/local/lib
└── fs@0.0.1-security

/usr/local/lib
└── require@2.4.20

/usr/local/lib
└── jsdom@18.0.1

/usr/local/lib
└── (empty)

/usr/local/lib
└─┬ jsdom@18.0.1
  └── form-data@4.0.0

/usr/local/lib
└── jsdom@18.0.1

/usr/local/lib
├── @types/node@16.11.6
├── axios@0.24.0
├── canvas@2.8.0
├── crypto-js@4.1.1
├── date-fns@2.25.0
├── dotenv@10.0.0
├── fs@0.0.1-security
├── js-base64@3.7.2
├── jsdom@18.0.1
├── npm@8.1.3
├── png-js@1.0.0
├── pnpm@6.10.3
├── requests@0.3.0
├── require@2.4.20
├── ts-md5@1.2.9
├── tslib@2.3.1
└── typescript@4.4.4

/usr/local/lib
└── js-base64@3.7.2

/usr/local/lib
└─┬ jsdom@18.0.1
  └── tough-cookie@4.0.0

/usr/local/lib
└── (empty)

/usr/local/lib
└── fs@0.0.1-security

/usr/local/lib
└── (empty)

/usr/local/lib
└── (empty)

/usr/local/lib
└── (empty)

root@qinglong2:/ql/scripts $ 


 

版权声明:
作者:烟雨
链接:https://www.yanyuwangluo.cn/84/
来源:烟雨阁
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
打赏
海报
青龙依赖安装与检查
依赖安装 docker exec -it 容器名/容器ID bash -c "npm install -g date-fns axios require request fs crypto-js crypto dotenv png-js tough-cookie got ts-……
< <上一篇
下一篇>>
文章目录
关闭
目 录